Skip to product information

Yealink SIP-T88V Pro IP HD Android Phone

SKU AC94895 Model# SIP-T88V-P
Yealink SIP-T88V Pro IP HD Android Phone(SIP-T88V-P) - 1

Yealink SIP-T88V Pro IP HD Android Phone

Description
SKU AC94895 Model# SIP-T88V-P
• Yealink SIP-T88V Pro IP HD Android Phone 7" 1024 x 600 capacitive adjustable touch screen
• Call recording
• I/O: Dual-port Gigabit Ethernet, 2x USB 2.0 port (Type-A/Type-C), 1x Security lock port, 1x RJ-9 (4P4C) handset port, 1x RJ-9 (4P4C) headset port
• Dimension: WDHT 263.7 mm x 206.9 mm x 261.0 mm x 38.9 mm
• Camera: 5mp , Adjustable, privacy shutter, plug and play
• Connectivity: WiFi, BT5.0
• SIP-T88V-P
View full item details
$661.95
Sale price  $661.95
Awaiting stock

In stock with supplier

Ships within 12 - 28 days

Payment plan Payment plan Payment plan
Payment plan
Payment plan Payment plan Payment plan
Payment plan
Bank Transfer

BANK TRANSFER (EFT)

Help icon

Need help? Ask our team

Email
Promotional banner
$661.95
Sale price  $661.95
Awaiting stock

In stock with supplier

Ships within 12 - 28 days

Accepted payment methods

  • Visa
  • Mastercard
  • American Express
  • PayPal
  • UnionPay
  • Alipay
  • WeChat Pay
  • LatitudePay
Help icon

Need help? Ask our team

Email
Description
• Yealink SIP-T88V Pro IP HD Android Phone 7" 1024 x 600 capacitive adjustable touch screen
• Call recording
• I/O: Dual-port Gigabit Ethernet, 2x USB 2.0 port (Type-A/Type-C), 1x Security lock port, 1x RJ-9 (4P4C) handset port, 1x RJ-9 (4P4C) headset port
• Dimension: WDHT 263.7 mm x 206.9 mm x 261.0 mm x 38.9 mm
• Camera: 5mp , Adjustable, privacy shutter, plug and play
• Connectivity: WiFi, BT5.0
• SIP-T88V-P
View Full Details

Frequently bought with

Yealink SIP-T88V Pro IP HD Android PhoneYealink SIP-T88V Pro IP HD Android PhoneYealink SIP-T88V Pro IP HD Android PhoneYealink SIP-T88V Pro IP HD Android PhoneYealink SIP-T88V Pro IP HD Android Phone


 

Audio HD voice HD handset, HD speaker
  Hearing aid compatible (HAC) handset Yes
  Acoustic Shield Yes
  Smart Noise Filtering Yes
  Audio codec AMR-WB (optional), G.722
  Narrowband codec AMR-NB (optional), PCMU (G.711μ), PCMA (G.711A), G.723.1, G.729, G.729A, G.729B, G.729AB, G.726, iLBC
  DTMF In-band, Out-of-band (RFC 2833), SIP INFO
  Full-duplex hands-free speakerphone With AEC
  Voice processing VAD, CNG, AEC, PLC, AJB, AGC
     
Display and Indicator LCD screen 7" 1024×600 capacitive adjustable touch screen
  LCD screen tilt Vertical tilt angle adjustable: 30°
  Multi-touch 5-point multi-touch surface
  Screensaver & Wallpaper Supported
  LED indication Call and message waiting
  User interface Icons and soft keys
  Multilingual UI Supported
  Caller ID Name, number, photo
     
Phone Features Yealink SDK Supported
  VoIP accounts 16
  One-touch features Speed dial, hotline, mute, DND
  Call features Hold, forward, waiting, transfer
  Group listening Supported
  Emergency call Supported
  Redial/return Redial, call return, auto answer
  Direct IP call Without SIP proxy
  Ringtones Selection/import/delete
  Date/time Manual or automatic
  Dial plan Supported
  XML Browser Supported
  Action URL/URI Supported
  RTCP-XR RFC3611
  VQ-RTCPXR RFC6035
  Conferencing 10-party audio (3-party video + 7-party audio)
  Data import/export Via Bluetooth, email, etc.
  DoorPhone features Preview, One-button Open
  Monitoring Supported
  USB/Bluetooth connectivity CP series speakerphones, UH & BT headsets
  Headset basic functions Answer/end, call mute
  Headset enhanced functions Audio optimization, redial, call hold, volume sync, multi-call control
  Analog PSTN calls Via CPN10
  Wireless Access Point AP mode
     
Android-bundled Applications Built-in apps FileManager, Email, Calendar, Camera, Gallery, Recorder, Calculator, Browser, Message
  Third-party apps Supported
     
IP-PBX Features BLF/BLA Supported
  Anonymous call Supported
  Anonymous call rejection Supported
  Remote office Supported
  Hot desking Supported
  Intercom Supported
  Paging Supported
  Call completion Supported
  MWI Supported
  Voice mail Supported
  Call park Supported
  Call pickup Supported
  Music on hold Supported
  Call recording Supported
     
Video Features Video codec H.264 High Profile, H.264, VP8
  Video quality 720P (1280×720) 30fps (≥512 kbps)
  Camera megapixels 5 MP
  Camera Plug and play
  Camera adjustability Adjustable
  Camera privacy Privacy shutter + LED indicator
  Camera tilt Vertical tilt 47°±3°
  Field of view 75°±5°
  Self view Local video preview
     
Function Keys DSS keys 84 one-touch
  Feature keys Hold, transfer, message, headset, mute, redial, speakerphone
  Volume control Supported
  Illuminated keys Mute/headset/hands-free
     
Interface Ethernet Dual-port Gigabit
  PoE IEEE 802.3af, Class 3
  Wi-Fi Dual-band 802.11a/b/g/n/ac/ax
  Wi-Fi frequency 2.4GHz / 5.0GHz
  Bluetooth Built-in Bluetooth 5.0
  Bluetooth supports BTH88 handset, headsets, mobile pairing
  Simultaneous BT connections One headset + one mobile phone
  USB ports 2× USB 2.0 (Type-A / Type-C)
  USB uses Flash drive, USB headset, expansion modules, EHS40
  Security lock port 1×
  Handset port 1× RJ-9
  Headset port 1× RJ-9
  Expansion modules Up to 3 color-screen modules
     
Other Physical Characteristics Operating humidity 5%–90%
  Operating temperature -10 to 45°C (14–113°F)
  Storage temperature -30 to 70°C
  Power adapter (optional) AC 100–240V → DC 12V/1.25A
  USB output 5V/500mA
  Power consumption (PoE) 2.79W–5.37W
  Power consumption (PSU) 2.06W–4.45W
  Dimensions 263.7×206.9×261.0×38.9 mm
     
Management Configuration modes Web, phone, auto-config
  Auto update FTP/TFTP/HTTP/HTTPS
  PnP deployment Supported
  Broadsoft device management Supported
  Zero-Sp-Touch Supported
  TR-069 Supported
  Keyboard lock Supported
  Factory reset & restart Supported
  Packet capture Supported
  System log export Supported
  YDMP/YMCS Supported
     
Network and Security IP versions IPv4/IPv6
  SIP v1 (RFC2543), v2 (RFC3261)
  Redundant servers Supported
  STUN Supported
  SIP modes Proxy, point-to-point
  IP assignment Static/dynamic
  SNTP Automatic date/time
  Protocols UDP/TCP/DNS-SRV
  QoS 802.1p/Q, ToS DSCP
  SRTP Supported
  TLS TLS 1.3
  HTTPS certificate management Supported
  Config encryption AES256
  Authentication MD5/SHA1/SHA224/SHA256/SHA384/SHA512
  VPN OpenVPN, IEEE802.1X, L2TP
  LLDP/CDP/DHCP VLAN Supported
  ICE Supported
  WPA2/WPA3 Supported
  Secure Boot Supported
  GARP Supported
     
Package Features Package contents SIP-T88V Pro IP phone, BTH88 handset, 2m CAT5E cable, stand, QSG, optional power adapter, optional wall mount
  Qty per carton 3 pcs
  Net weight 5.332 kg
  Gross weight 4.836 kg
  Giftbox size 290×288×104 mm
  Carton size 324×275×305 mm

 

 

Loading reviews...
Loading reviews...

You may also like