Skip to product information

Winstars WN688U3 AC1300M Dual-Band Wi-Fi USB 3.0 Adapter

SKU AC07291 Model# WN688U3
Winstars WN688U3 AC1300M Dual-Band Wi-Fi USB 3.0 Adapter(WN688U3) - 1

Winstars WN688U3 AC1300M Dual-Band Wi-Fi USB 3.0 Adapter

Description
SKU AC07291 Model# WN688U3
• Winstars WN688U3 AC1300M Dual-Band Wi-Fi USB 3.0 Adapter Support 2.4GHz & 5GHz WLAN networks
• Dual Band connections for lag-free HD video streaming and gaming
• Support 2.4GHz & 5GHz WLAN networks
• WN688U3
• 12 Months Limited Warranty
View full item details
$20.95
Sale price  $20.95
Awaiting stock

In stock with supplier

Ships within 12 - 28 days

Payment plan Payment plan Payment plan
Payment plan
Payment plan Payment plan Payment plan
Payment plan
Bank Transfer

BANK TRANSFER (EFT)

Help icon

Need help? Ask our team

Email
Promotional banner
$20.95
Sale price  $20.95
Awaiting stock

In stock with supplier

Ships within 12 - 28 days

Accepted payment methods

  • Visa
  • Mastercard
  • American Express
  • PayPal
  • UnionPay
  • Alipay
  • WeChat Pay
  • LatitudePay
Help icon

Need help? Ask our team

Email
Description
• Winstars WN688U3 AC1300M Dual-Band Wi-Fi USB 3.0 Adapter Support 2.4GHz & 5GHz WLAN networks
• Dual Band connections for lag-free HD video streaming and gaming
• Support 2.4GHz & 5GHz WLAN networks
• WN688U3
• 12 Months Limited Warranty
View Full Details

Frequently bought with

Features

  • 1300 (867+400)Mbps wireless speed
  • Support 2.4GHz & 5GHz WLAN networks
  • Dual Band connections for lag-free HD video streaming and gaming
  • SuperSpeed USB 3.0 port, backward compatible to USB 2.0
  • Complies with IEEE 802.11ac, IEEE 802.11n, IEEE 802.11g, IEEE 802.11b standards
  • 20MHz & 40MHz & 80MHz bandwidth transmission
  • OFDM with BPSK, QPSK, 16QAM, 64QAM, 256QAMmodulation
  • Supports Windows XP / Vista / 7 / 8 / 8.1/10, MAC

Specification

  • Hardware 
    • Ports: USB 3.0
    • Button: WPS 
    • LED: 1 X Link/ Active
    • Chipset:RTL8812AU 
    • Flash: N/A 
    • SDRAM: N/A 
    • Power Supply: USB 5V 
    • Power Plug: N/A 
    • Power Consumption:/ 
    • Rated Voltage/ requency /current:DC 5V about 500mA
  • Wireless 
    • Standard:IEEE802.11ac,IEEE 802.11a, IEEE 802.11b,IEEE 802.11g,IEEE 802.11n
    • Modulation:
      • 11ac\n: 16QAM, 64QAM 128QAM 256QAM with OFDM
      • 11g: BPSK, QPSK, 16QAM, 64QAM, OFDM
      • 11b: DQPSK, DBPSK, DSSS, CCK 
    • Speed:
      • 802.11ac: up to 867Mbps 
      • 802.11n: up to 400Mbps 
      • 802.11a: up to 54Mbps 
      • 802.11g: 54 M 
      • 802.11b: 11 M 
    • Frequency band:5GHz and 2.4GHz 
    • Power: 
      • 802.11b: 22dBm ± 2 dBm 802.11g: 16dBm ± 2 dBm 
      • 802.11n: 15dBm ± 2 dBm 802.11ac: 14dBm ± 2 dBm 
    • Distance:Outdoors 300m, Indoor 100m(According to the actual environment change)
    • Safely 64/128-bit WEP, AES,TKIP,WPA,WPA2,802.1x,WPA-PSK,WPA2-PSK,MAC, WDS
  • Environmental 
    • Operating Temperature:0ºC~40ºC 
    • Storage Temperature:-10~70? 
    • Relative Humidity(Operational): 10%~90%,noncondensing 
    • Relative Humidity(Storage):10%~90%,noncondensing
  • Software
    • Standard Version 
      • RFC768 User Datagram Protocol(UDP)
      • RFC791 Internet Protocol(IP) 
      • RFC792 Internet Control Message Protocol
      • RFC793 Transmission Control Protocol(TCP)
      • bandwidth:20MHz?40MHz?80MHz
      • Wireless Mode:11ac only, 11n only, 11g only?11b only(option)
      • System Windows XP / Vista / 7 / 8 / 8.1/10, MAC

Product weight and dimensions

  • Item Weight: 0.25 KG
  • Product Dimensions: 98mm L x 28mm W x 10mm (L x W x H)
12 Months Limited Warranty
Dual Band connections for lag-free HD video streaming and gaming
Support 2.4GHz & 5GHz WLAN networks
Winstars WN688U3 AC1300M Dual-Band Wi-Fi USB 3.0 Adapter
WN688U3
Loading reviews...
Loading reviews...

You may also like